Google OAuth Signup Flow Disruption
Incident Report for Pulzeai Inc
Postmortem

Incident Description: We recently transitioned to our own authentication domain (auth.pulze.ai) and failed to apply necessary changes to the sign-up flow process, which caused a disruption in the service. This issue specifically affected the integration with Google OAuth, thereby hindering new users from signing up to our service using their Google accounts.

Impact: This disruption caused potential new users to be unable to sign up using Google OAuth during the affected period, which may have impacted user acquisition rates and overall user experience.

Root Cause: The root cause of the incident was an oversight during the transition to the new authentication domain. The sign-up flow process was not updated to reflect the change, resulting in a mismatch between the system configurations and the actual process.

Resolution: Upon identifying the issue, the necessary changes were made to the sign-up flow to align with the new authentication domain. We have since confirmed that the sign-up process via Google OAuth is functioning correctly.

Preventive Measures: To prevent similar occurrences in the future, we have identified the need for a comprehensive checklist and transition process for such changes. This would include a more robust testing phase to ensure all functionalities work as expected after any changes.

Posted Jul 22, 2023 - 22:42 UTC

Resolved
We recently transitioned to our own authentication domain (auth.pulze.ai) and failed to apply necessary changes to the sign-up flow process, which caused a disruption in the service. This issue specifically affected the integration with Google OAuth, thereby hindering new users from signing up to our service using their Google accounts.
Posted Jul 22, 2023 - 22:38 UTC